6.0.0-git
2020-01-22

Diff for IMPNoMessageText between 5 and 6

++ Why is IMP Not showing the text of my message?

//99.99%// of the time this is for two reasons.  Here are the things to look for:

+++ You can't see **any** message, or your folders are empty, or other random stuff is going on with your mailboxes

Your c-client and PHP combination is almost certainly the culprit.  For whatever reason, sometimes PHP and your local c-client version just don't get along.  Strangely enough, you may not receive any errors at all while compiling PHP but when using IMP you will see strange behavior.  If this is the case, the first step is simply to upgrade your PHP and/or version of c-client and recompile.  Sometimes, just re-compiling PHP without changing anything will cause it to work.  Don't ask us what's up with that.

Another issue occurs when a malformed message in a folder crashes c-client.  Generally this occurs when a malformed MIME header in a message (much of the time from a spam message) causes a buffer overflow error (or something similar) in c-client.  There is nothing IMP can do about this, and it's probably a **really** good idea to upgrade anyway due to the security concerns alone.

+++ **One message** is giving you a "No parts can be displayed inline" message.  Or a text/html message is being displayed in raw text.  Or you can't see an attachment you *know* is in the message.

This is amost certainly *not* an IMP problem.  Before you go and run to our bug reporting system or mailing lists and complain that we aren't displaying messages correctly, please look at the following:

[http://marc.theaimsgroup.com/?l=imp&m=113769471406739&w=2[http://marc.info/?l=imp&m=113769471406739&w=2 Content-Transfer-Encoding header issue]
[http://lists.horde.org/archives/imp/Week-of-Mon-20040209/036646.html MIME-Version header issue]
[http://bugs.horde.org/ticket/?id=3367 You have turned on inline viewing of HTML, right?]
...more to come

Obviously, there is a chance it may be a bug but it usually isn't.